Hyperledger Fabric 1.4 环境搭建-CentOS

时间:2019-03-28作者:klpeng分类:JS/Shell浏览:6058评论:0

偷得浮生半日闲!

Hyperledger Fabric 1.4 已经发布一段时间,作为第一个长期支持的版本,我在这里整理一下使用Hyperledger Fabric 1.4 的过程。

一、软件安装(我的是在VitualBox 的 CentOS 7.6 系统下安装)

1、Docker 要求 CentOS 系统的内核版本高于 3.10 ,查看本页面的前提条件来验证你的CentOS 版本是否支持 Docker 。

通过 uname -r 命令查看你当前的内核版本

$ uname -r

 

2、使用 root 权限登录 Centos。确保 yum 包更新到最新。

$ sudo yum update

 

3、卸载旧版本(如果安装过旧版本的话)

$ sudo yum remove docker docker-common docker-selinux docker-engine

 

4、安装需要的软件包, yum-util 提供yum-config-manager功能,另外两个是devicemapper驱动依赖的

$ sudo yum install -y yum-utils device-mapper-persistent-data lvm2

 

5、设置yum源

$ sudo yum-config-manager --add-repo https://download.docker.com/linux/centos/docker-ce.repo

 

6、关闭测试版本list(只显示稳定版)

sudo yum-config-manager --enable docker-ce-edge

sudo yum-config-manager --enable docker-ce-test

 

7、可以查看所有仓库中所有docker版本,并选择特定版本安装

$ yum list docker-ce --showduplicates | sort -r

 

8、更新yum包索引

yum makecache fast

 

9、安装docker ( Docker version Docker 17.06.2-ce or greater is required)

$ sudo yum install docker-ce #安最新稳定版

 

10、启动并加入开机启动

$ sudo systemctl start docker

$ sudo systemctl enable docker

 

11、验证安装是否成功(有client和service两部分表示docker安装启动都成功了)

$ docker version

 

12、启动并加入开机启动

$ sudo systemctl start docker

$ sudo systemctl enable docker

$ sudo systemctl status docker

 

14. 安装Docker Compose (you should check that you have Docker Compose version 1.14.0 or greater installed)

$ sudo curl -L "https://github.com/docker/compose/releases/download/1.23.2/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose

$ sudo chmod +x /usr/local/bin/docker-compose

$ docker-compose -v

 

15. centos 7.5 开始已默认安装了phyton 2.7.5

$ python --version

 

16. node安装 (you will need to have version 8.9.x of Node.js installed)

 

$ tax -xvf node-v8.9.4-linux-x64.tar.gz -C /usr/local/

$ node -v

$ npm -v

$ npm config set registry https://registry.npm.taobao.org

$ npm config get registry

 

安装express module测试

$ npm install express -g

 

18. 安装git

$ yum install git

$ git --version

 

19. 安装go (Go version 1.11.x is required.)

 

20. /etc/profile文件配置

export GOROOT=/usr/local/go/go

export GOBIN=$GOROOT/bin

export GOPKG=$GOROOT/pkg/tool/linux_amd64

export GOARCH=amd64

export GOOS=linux

export GOPATH=/root/workspace/go

export NODEPATH=/usr/local/node-v8.9.4-linux-x64

export PATH=$PATH:$GOBIN:$GOPKG:$GOPATH/bin:$NODEPATH/bin

 

二、源码下载

1. 下载Fabric源码和镜像

$ mkdir $GOPATH/src/github.com/hyperledger

$ cd $GOPATH/src/github.com/hyperledger

$ git clone https://github.com/hyperledger/fabric.git

$ cd fabric/script

$ ./bootstrap.sh

 

2. 构建网络,生成配置

$ cd fabric/scripts/fabric-samples/first-network/

$ ./byfn.sh generate

Hyperledger Fabric 1.4 环境搭建-CentOS

3. 启动网络

$ ./byfn.sh up

 Hyperledger Fabric 1.4 环境搭建-CentOS

 耐心等待,出现如下界面之后证明网络已经启动成功

  Hyperledger Fabric 1.4 环境搭建-CentOS

$ docker ps -a #查看所有启动的容器

 

4. 关闭网络

$ ./byfn.sh down

 

可以直接查看byfn.sh文件 或执行byfn.sh -h 了解相关命令

Hyperledger Fabric 1.4 环境搭建-CentOS

 

问题: WARNING: IPv4 forwarding is disabled. Networking will not work.

vi /usr/lib/sysctl.d/00-system.conf

添加:net.ipv4.ip_forward=1

然后执行 systemctl restart network

 

 

 

 

 

 

 

打赏
文章版权声明:除非注明,否则均为彭超的博客原创文章,转载或复制请以超链接形式并注明出处。
相关推荐

发表评论:

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。

猜你喜欢