我对hyperledger fabric1.1.0的执着(一):基本环境整理

时间:2018-11-09作者:klpeng分类:IT综合浏览:1973评论:0

我用的操作系统为:centos7.4,语言准备用java开发。

整理包括:linux内核升级(若升级失败,可参考https://blog.csdn.net/tianshuhao521/article/details/84021064),jdk安装,docker(docker ce,docker-compose)安装,go语言环境安装。

1、Docker要求的linux内核版本最低为3.10,故需将linux内核升级到4.x,并更新本地依赖,一般执行以下命令即可:

      sudo yum update

我对hyperledger fabric1.1.0的执着(一):基本环境整理

最后complete!表示更新成功。

2、安装jdk(我用的1.8):

(2.1)官网下载tar.gz安装包,上传至自己的目录,我这里是/home/develop/java/jdk

(2.2)进入/home/develop/java/jdk目录并解压安装包:

cd /home/develop/java/jdk

tar -zxvf jdk-8u181-linux-x64.tar.gz

(2.3)配置环境变量:

(2.3.1)输入命令:vim /etc/profile

(2.3.2)点击i或者o进入编辑模式

(2.3.3)在最后添加以下内容(JAVA_HOME为自己的安装目录):

#java environment
export JAVA_HOME=/home/develop/java/jdk/jdk1.8.0_181
export CLASSPATH=.:${JAVA_HOME}/jre/lib/rt.jar:${JAVA_HOME}/lib/dt.jar:${JAVA_HOME}/lib/tools.jar
export PATH=$PATH:${JAVA_HOME}/bin

(2.3.4)按esc键进入命令模式,输入:wq保存并退出vim。

(2.3.5)输入命令source /etc/profile使文件生效。

(2.3.6)输入命令java -version查看jdk版本,如图:

我对hyperledger fabric1.1.0的执着(一):基本环境整理

3、安装Docker

(3.1)如果以前安装过Docker,需要先卸载,命令如下:

# sudo yum remove docker docker-client docker-client-latest docker-common docker-latest docker-latest-logrotate docker-logrotate docker-selinux docker-engine-selinux docker-engine

我以前没有安装过,所以提示以下信息:

我对hyperledger fabric1.1.0的执着(一):基本环境整理

(3.2)在线安装docker ce

(3.2.1)安装yum-utils提供的yum-config-manager,device-mapper-persistent-data和lvm2,命令如下:

sudo yum install -y yum-utils device-mapper-persistent-data lvm2

我对hyperledger fabric1.1.0的执着(一):基本环境整理

最后complete!

(3.2.2)设置稳定存储库:

sudo yum-config-manager --add-repo https://download.docker.com/linux/centos/docker-ce.repo

我对hyperledger fabric1.1.0的执着(一):基本环境整理

(3.2.3)可以选择性的启用edge和测试存储库,这些存储库包含在Docker中,默认是禁用的,命令如下:

sudo yum-config-manager --enable docker-ce-edge
sudo yum-config-manager --enable docker-ce-test

(3.2.4)以下命令为禁用edgecunc存储库:

sudo yum-config-manager --disable docker-ce-edge

(3.2.5)安装最新版的Docker CE:

sudo yum install docker-ce

我对hyperledger fabric1.1.0的执着(一):基本环境整理

最后complete!

(3.2.6)查看docker版本,如图表示安装成功:

docker --version

我对hyperledger fabric1.1.0的执着(一):基本环境整理

(3.2.7)启动docker:systemctl start docker     (有些版本的启动命令为service docker start)

(3.2.8)设置docker开机自启:chkconfig docker on

(3.3)安装Docker-Compose(离线安装)

(3.3.1)若是在线安装docker-compose需要先安装curl,离线安装虽然这里用不到,但也可以安装一下,以后会有用,命令:

    yum install curl

(3.3.2)下载最新版的docker-compose-Linux-x86_64,下载地址为https://github.com/docker/compose/releases。下载完后上传至/tmp/docker/docker-compose文件夹下,若无此文件夹,创建即可。

(3.3.3)进入文件所在目录:cd /tmp/docker/docker-compose

(3.3.4)将其移动至/usr/local/bin安装目录:mv docker-compose-Linux-x86_64 /usr/local/bin/docker-compose

(3.3.5)赋予可执行权限:chmod +x /usr/local/bin/docker-compose

(3.3.6)查看版本信息:docker-compose --version

我对hyperledger fabric1.1.0的执着(一):基本环境整理

如图表示安装成功。

注意:若安装不成功,尝试一下以下命令:cp /usr/local/bin/docker-compose /usr/bin

4、安装Go语言环境

(4.1)下载go语言包:https://studygolang.com/dl

(4.2)将下载的语言包go1.11.linux-amd64.tar.gz上传至文件夹/tmp/docker

(4.3)进入/tmp/docker:cd /tmp/docker

(4.4)解压至/usr/local目录下:tar -C /usr/local -zxvf go1.11.linux-amd64.tar.gz

(4.5)配置go语言环境变量,参照配置jdk环境变量,在/etc/profile文件后加以下内容(别忘了使文件生效):

#go环境变量
export PATH=$PATH:/usr/local/go/bin
export GOPATH=/opt/gopath

(4.6)查看go版本:go version

我对hyperledger fabric1.1.0的执着(一):基本环境整理

 

至此,hyperledger fabric所需的基本环境即整理完成。

 

打赏
文章版权声明:除非注明,否则均为彭超的博客原创文章,转载或复制请以超链接形式并注明出处。
相关推荐

发表评论:

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。

猜你喜欢